Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the board
Thread view  Mix view  Order
CluelessInSeattl(R)

Seattle, USA,
21.03.2013, 14:32
 

AUTOEXEC & CONFIG Spring Cleaning? (Users)

I took a look at my old MS-DOS 6.21 AUTOEXEC.BAT and CONFIG.SYS files and realized that they are both haphazard patchworks that I can't begin to sort out.

These files go back to over a decade ago when I became disabled by chronic illness, lost my job and then my housing, so what I didn't end up tossing overboard I put into storage during a long stretch of homelessness.

I'm only now beginning to pick up where I left off with my MS-DOS project over ten years ago, and I can't recall what many of the lines in those files are supposed to do or why I ever put them in there in the first place.

Back then I was always experimenting and trying new tricks and didn't feel the need to put in comment lines to explain any changes I made.

So, since yesterday was the first day of spring, I'd like to try cleaning up my AUTOEXEC.BAT and CONFIG.SYS files.

If I were to post them here, is there anyone reading this who would be willing to take a look at them and offer advice on how to clean them up?

BTW, I can't figure out how to format code in my posts. The buttons on the side of Message window only seem to offer 5 choices:

bold
italic
link
image
upload

Am I supposed to manually insert an html marker or something like that?

---
Will in Seattle
a.k.a. "Clueless"
Running MS-DOS 6.21

Rugxulo(R)

Homepage

Usono,
21.03.2013, 17:29

@ CluelessInSeattl

AUTOEXEC & CONFIG Spring Cleaning?

> If I were to post them here, is there anyone reading this who would be
> willing to take a look at them and offer advice on how to clean them up?

Advice is easy, but having such code working is another matter. ;-)
In other words, it's easier to look and suggest than actually test and make sure it's 100% foolproof first.

It'd almost just be easier to point you to a downloadable FreeDOS image. But I guess you have reasons for sticking with MS-DOS (which is fine and I don't disagree, just saying, I can't test MS-DOS proper these days, e.g. the CONFIG.SYS menu stuff is different syntax).

> BTW, I can't figure out how to format code in my posts. The buttons on the
> side of Message window only seem to offer 5 choices:
>
> Am I supposed to manually insert an html marker or something like that?

No, you should be able to use [ code ] and [ /code ] (without the spaces):


@echo off
REM autoexec.bat
echo.
echo Hello, world!
echo.

Back to the board
Thread view  Mix view  Order
15192 Postings in 1365 Threads, 250 registered users, 15 users online (0 registered, 15 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum