Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

SOUND support in DOS | Piotr | HDA (Developers)

posted by RayeR(R) Homepage, CZ, 17.12.2011, 19:20
(edited by RayeR on 17.12.2011, 23:33)

> At that time, he sent me an Alpha version with HDA support up to ICH10. I
> mirrored it here:
> LINK
> If there's interest we could let him know of this thread, and maybe he
> resumes development to have a stable for Mplayer or something else :)

Nice, I'm going to test it. It would be nice to see it integrated in mplayer!

EDIT: Tested and it works (ICH7+ALC888)! but...
1) don't forget to unset old BLASTER env. var. because it tries to initialize your SB first - I had this var set bacause of partial working SB emu on SB live. So I unset it and it started. It's mentioned in readme.

2) the playback works well, smooth and good quality sound without any crackles, volume control works... Just one confusing thing is empty ioport/dma/irq value (see below, or is it due to HDA? even HDA should have some IO base and irq)

3) I tried it to compile under DJGPP 2.04/GCC 4.6.2 and it spit a lot of warnings and compiled binaries didn't work - it just blacken the screen and hangs.

4) I tried it to compile under Watcom C 11.0c and compiled binaries works fine. I think that it must got messed something with newer gcc and older may work - what version of GCC did you used? I'll try to clean up the warnings but maybe the problem is in asm part or its interconnection and then I'll be lost.

[image]

---
DOS gives me freedom to unlimited HW access.

 

Complete thread:

Back to the forum
Board view  Mix view
15192 Postings in 1365 Threads, 250 registered users, 18 users online (0 registered, 18 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum