Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

Change UDMA mode on WD400BB drive (Users)

posted by RayeR(R) Homepage, CZ, 06.01.2013, 21:20

Hi,
I'm trying to setup one DOS computer with Pentium Pro 200, Asus P6NP5 (intel 440FX + PIIX3 chipset). I put there 40GB WD400BB drive that supports max. UDMA133 that was enabled on the drive. The onboard IDE on this PC supports only UDMA33. Unfortunatelly for some reason UDMA don't work at all. Various info tools tells me that UDMA is not enable. And my benchmark shows me poor ~5MB/s reading. I suspect that this is because the drive was enabled for UDMA66+ and it fall back to safe non-DMA mode. I used latest UIDE under DOS 6.22 but it doesn't have any effect on speed. I remember there exist DGLGUDMA tool from Western Digital but latest version is crashing in all conditions:
http://rayer.g6.cz/1tmp/CWERR.TXT
I tried on different 2 PCs, bare DOS - no memory manager and himem.sys
I found older version but it doesn't support this drive. I also tried Hitachi Feature Tool but it cannot change UDMA mode on this drive. If I run new DGLGUDMA under DOSBox it doen't crash but don't find any drives, of course.
Do you know about any universal UDMA tool or how to overcome CauseWay crap error? Eg. if possible to strip the CW and replace by another extender...

---
DOS gives me freedom to unlimited HW access.

 

Complete thread:

Back to the forum
Board view  Mix view
15192 Postings in 1365 Threads, 250 registered users, 19 users online (0 registered, 19 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum