Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

Test MPLAYER (Sherpya) 2013-03-28 (DOSX)

posted by sherpya(R), 07.04.2013, 06:15

> Ok, the new DKRNL32.DLLs allow MPlayer to work without "SET DPMILDR=128" in
> the environment! (Tested latest svn-r36169.)
>
> Some notes/observations:
>
> * I must use the "DPMILD32 -g" syntax for both directx and sdl, else the
> screen output is garbled.
>
> * As before, "-vo sdl" works, but must press [F] 2x for fullscreen.
>
> * As before, "-vo sdl -fs" works, but must press [F] key 1x for fullscreen.
>
>
> * Now "-vo directx" works for me, but pressing [F] crashes.
>
> * "-vo directx -fs" crashes immediately.
>
> * HX errorlog contains the following when fullscreen crashes:
>
> MPlayer interrupted by signal 11 in module: flip_page
> - MPlayer crashed by bad usage of CPU/FPU/RAM.
> Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
> disassembly. Details in
> DOCS/HTML/en/bugreports_what.html#bugreports_crash.
> - MPlayer crashed. This shouldn't happen.
> It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
> gcc version. If you think it's MPlayer's fault, please read
> DOCS/HTML/en/bugreports.html and follow the instructions there. We can't
> and
> won't help unless you provide this information when reporting a possible
> bug.
>

> * A bunch of file types (including most MPG) seem to play ok but produce
> message "[VD_FFMPEG] DRI failure" in errorlog. Don't know if that's
> related.
>
> OS: real DOS 7.1 (no VM, no box), 4DOS 8.0, HX 2.17
> HW: P4, 845/ICH4, ATI Rage 128 (VBE 2.0)
>

I've noticed you don't need to go full screen if the resoultion in the .ini is the same of the video (obiviously).
Looks like it works only in fullscreen, but maybe -fs doesn't pick automatically the current resolution
Unfortunately isn't easy to debug. directx -fs works for me using kvm (qemu+vtd), so it may be something related to hxgui vesa calls. Can you run adding -v -v to command line? it should spam more on the log, thanks

Another suggestion (unrelated to your problem) is comment out font=Arial and set fontconfig=no in the config, you can get rid of fonts subdir, mplayer will pick mplayer\subfont.ttf

 

Complete thread:

Back to the forum
Board view  Mix view
15108 Postings in 1358 Threads, 247 registered users, 16 users online (1 registered, 15 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum