Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

Compilation Woes: A study in frustration. (Emulation)

posted by Zyzzle(R), 28.03.2014, 03:56

(I don't have a
> Colecovision machine, never tried any emulators, and I'm not sure of the
> legality in U.S. of getting the .ROMs without permission.)

I actually still have my old machine, but it no longer works reliably, hence the outreach for an emulator of sorts...

> Though he does have a Google Group about all his emulators, which is still
> very active, so you may have better luck asking all others there:

I discovered that newsgroup myself, but it seems swamped with Android and / or other cell phone emulator talk.

> Maybe he used NMAKE and not WMAKE. Maybe he had a quirky layout, but I
> don't see any obvious hints on which subdir to sit in when running wmake -f
> whatever. The few things I tried also didn't work. Maybe the sources are
> broken and don't compile out of the box. It may be a mistake to assume it
> works at all if he hasn't maintained it lately.

Actually, the possibility that NMAKE was needed to compile the makefile was not lost on me, but I couldn't locate a DOS version of NMAKE, only a 32-bit Windows version of NMAKE v. 1.5. So I was stuck with wmake from Open Watcom. I did notice it had an -ms switch which purported to make it compabible with NMAKE, but it didn't solve the problem.

> @echo off
> echo unix wget
> if "%WATCOM%"=="" goto end
> md colem
> cd colem
> unzip -qCjn ..\
> for %%a in (colem coleco menu msdos sound libmsdos console emulib z80 image
> tms9918 drv9918 sn76489) do ren %%a.c *.c~
> del *.exe >NUL
> del *.c >NUL
> ren *.c~ *.c
> wcl386 -zq -zp4 -5r -otexan -l=dos4g -fe=colem.exe -DBPP16 -DMSDOS -DCOLEM
> *.c
> if exist colem.exe dir colem.exe
> REM COLEM    EXE       219,362  03-27-14  9:28a colem.exe
> :end

Thanks for that ingenious batch file. I managed to compile it, but I had to set #define LSB_FIRST 0x1 in the file COLECO.h as your version produced a little-endian one (did you cross-compile on a Linux machine?). After a recompile with your batch file, it loaded with DOS4G but issued the same behavior as the precompiled DOS32A COLEM.EXE binary included in author's original package.

I did some more digging and found that a bug / incompability was introduced somewhere between v. 2.2 and 2.3 which prevents the ROMs from loading. Versions 2.2 and below work great for me in plain DOS. If I could find the source to version 2.3, I might be able to troubleshoot the problem, but it seems to have vanished.

So, I came round full circle and realized it is a newly-introduced bug and NOT any system incompatibility and / or DOS extender problem! What progress.

Thanks for your hints, help and pointers, it provided the impetus to troubleshoot this.

In the meantime, I've found a Windoze emulator called BlueMSX which will emulate the Coleco machine.

Looks like if I want to run it in good ol' DOS, I'm stuck with ColEm 2.2 instead of the 2.6 version.


Complete thread:

Back to the forum
Board view  Mix view
15317 Postings in 1383 Threads, 254 registered users, 9 users online (0 registered, 9 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum