Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

Fun with vDOS (Emulation)

posted by bocke(R), 05.11.2014, 16:02

> I did compile and run it in Fedora 20 within VMware Workstation 10. The
> only problem I found so far is that with SDL port of PDCurses the
> copy/paste only works inside DOSBox, but not outside DOSBox, since the
> "clipboard" it uses is independent of the Linux or X11 clipboard. The
> Windows port of PDCurses does not have this problem however (I also found a
> solution for MacOS X system too). Have you tried the X11 port of PDCurses?

I tried that first. It didn't work.

> Apart from the above known issue, I have not been able to reproduce the
> other problems that you described. I have confirmed during my testing that
> DOSBox's CD command is case insensitive even running in Linux. Also Doszip
> commander (3.31) did not crash after trying to navigate out of the
> directory where it started in my testing. Maybe some source files used in
> your compilation are incorrect?

I used the files from the archive... I recreated it at least twice. So I would think not.

Sorry, I forgot to mention I was building on 64-bit Linux. I can try building on 32-bit Linux.

Or maybe I could take a look at Fedora srpm .spec file to see if they apply any patches to their pdcurses build.


Complete thread:

Back to the forum
Board view  Mix view
15317 Postings in 1383 Threads, 254 registered users, 18 users online (0 registered, 18 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum