Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

xvisor (Developers)

posted by RayeR(R) Homepage, CZ, 12.03.2015, 19:02
(edited by RayeR on 12.03.2015, 19:37)

I know that makefiles use tabs instead spaces but I had problem with *.dep files that are generated automatically by Makefile. Even I cannot run "make distclean" because it stopped at error on first *.dep file. So I recursively deleted all *.dep run make clean and distclean again that passed. I run make menuconfig and make again and I got much further. Compiling stopped at error:

/home/public/xvisor-0.2.5/build/arch/x86/cpu/cpu.o: In function `arch_guest_add_region':
/home/public/xvisor-0.2.5/arch/x86/cpu/x86_64/arch_guest_helper.c:105: undefined reference to `enable_ioport_intercept'
/home/public/xvisor-0.2.5/build/arch/x86/cpu/cpu.o: In function `arch_guest_del_region':
/home/public/xvisor-0.2.5/arch/x86/cpu/x86_64/arch_guest_helper.c:134: undefined reference to `disable_ioport_intercept'
/home/public/xvisor-0.2.5/build/arch/x86/cpu/cpu.o: In function `cpu_init_vcpu_hw_context':
/home/public/xvisor-0.2.5/arch/x86/cpu/common/vm/vm.c:161: undefined reference to `amd_setup_vm_control'
/home/public/xvisor-0.2.5/build/arch/x86/cpu/cpu.o: In function `cpu_enable_vm_extensions':
/home/public/xvisor-0.2.5/arch/x86/cpu/common/vm/vm.c:201: undefined reference to `init_amd'
collect2: error: ld returned 1 exit status
make: *** [/home/public/xvisor-0.2.5/build/vmm_tmp1.elf] Error 1

I guessed that sources for intel and amd virt. are not well separated because I selected only intel vt-x and it's trying to compile something for amd. So I run menuconfig again and selected both AMD-SVM and intel VT-x. Then I got another nice error:

/home/public/xvisor-0.2.5/arch/x86/board/x86_64_generic/hpet.c: In function ?hpet_clockchip_init?:
/home/public/xvisor-0.2.5/arch/x86/board/x86_64_generic/hpet.c:394:7: error: ?struct hpet_timer? has no member named ?clkcip?
  timer->clkcip.cpumask = vmm_cpumask_of(target_cpu);
       ^
/home/public/xvisor-0.2.5/arch/x86/board/x86_64_generic/hpet.c:412:38: error: ?irqno? undeclared (first use in this function)
  if ((rc = vmm_host_irq_set_affinity(irqno,
                                      ^
/home/public/xvisor-0.2.5/arch/x86/board/x86_64_generic/hpet.c:412:38: note: each undeclared identifier is reported only once for each function it appears in
make: *** [/home/public/xvisor-0.2.5/build/arch/x86/board/x86_64_generic/hpet.o] Error 1

I guessed that I have to disable multiprocessor host support. Then it finally compiled something, I got build/vmm.bin. Warning, if you do make clean, entire build directory is removed with your .config file (I guess it should be placed in top dir and not in build dir). All this seems very experimental, dirty and crappy...

---
DOS gives me freedom to unlimited HW access.

 

Complete thread:

Back to the forum
Board view  Mix view
15188 Postings in 1365 Threads, 250 registered users, 17 users online (0 registered, 17 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum