Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

New XIDE driver (5.6.2015) from Jack - test result (Announce)

posted by Laaca(R) Homepage, Czech republic, 17.06.2015, 21:39

Guys, I have much more serious problem with UIDE and XIDE.
It seems it can provocate an incompatibility with programs using Borland's exteders RTM.EXE and DPMI16BI.OVL

If I have 80MB cache everything is OK.
But if I set another value - (bigger: DEVICE=C:\FREEDOS\XIDE.SYS /S160 /P) but suprisingly also lower (DEVICE=C:\FREEDOS\XIDE.SYS /S40 /P) evil things happen.

If I run any program using RTM & DPMI16BI.OVL like BP.EXE from Borland pascal 7.0 the program immediately collapses with error message: "Ignoring (and losing) VCPI page! - beyond table." This message prints on screen about 500 times and then it ends with another message. In some cases: "JemmEx: exception 06 occured at..." and computer freezes or with exception 0E which is better because computer does not freeze.

Some notes:
1) parameter /P makes no change, other parameters I tried also don't change anything. The same issue had also UIDE.SYS

2) It occurs on my both DOS machines: P4 with 512MB RAM and P2 with 192MB RAM.
Both use JemmeX memory extender in config.sys with A20 parameter.
I was investigating this problem quite deeply few months ago and I was not able to find other possible cause in my setup than UIDE/XIDE

---
DOS-u-akbar!

 

Complete thread:

Back to the forum
Board view  Mix view
15115 Postings in 1359 Threads, 249 registered users, 26 users online (1 registered, 25 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum