Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

Quake 2 port for DOS, now with HDA sound! (Announce)

posted by Rugxulo(R) Homepage, Usono, 30.06.2015, 20:48

> Yeah, I must admit there are some issues. E.g. watcom/pmodew crashes on my
> machine.

He actually just (coincidentally?) uploaded a new Watcom compile yesterday, and now Tab key (map) works.

> But I observe it's not uncommon that pmodew doesn't like with
> jemmex (at most on my PC)...

I don't normally use JEMMEX, only XMGR or HIMEMX.

There are many extenders, but only some of them work some of the time. :-|

> DJGPP version of Zdoom was quite playable,

That .EXE didn't work at all for me, wouldn't even start.

> I didn't need map in first episode :)

Me either except in rare cases. Sometimes you get tired of running in circles. ;-)

Hexen2 is worse about that (though expansion pack allegedly fixed that, yet which I don't have), no map at all. Lots of backtracking and minimal but confusingly arcane clues.

> It played nice on my SB Audigy 2 in 1024x768 with mouse enhancements.

I also tried under my old P4 (EMU10k1) but no sound. But Mpxplay doesn't work there either, so I dunno, it's probably too old for devs to care about anymore. HDA seems the preferred mainstream target these days (although it didn't work on my laptop either, yet main desktop is fine). Yeah, drivers are a mess.

> But I have trouble with Ruslan's Quakedos. I recompiled it with -O1 as he
> has in makefile with gcc 4.8.4 and it crashes when you select New game. So
> I relaxed to -O0 and it plays then but crashes at exit to DOS. And even, it
> messed my FAT16 FS! Some crashes cause only temporal mess up e.g. when you
> tyope dir you got total garbage but after hardreset it booted and FS seemed
> to be OK. But then I got heavy mess up of entire 2GB C: partition (game was
> ran from different one I:\QUAKE) and I have to restore backup because
> directory structure was gone. After some time I got an idea what could
> happened - I use UIDE with it's large cache. I suspect that program crashed
> so hard to hit the cache area. If it use __djgpp_nearptr_enable() it can be
> very evil because it makes protected mode unprotected. So when I do hard
> reset, the cache couldn't flush to disk and FS leaves untouched by angel of
> death but when I do crtl+alt+del it probably write corrupted data to HDD.
> Binary provided by Ruslan seems not tend to crash, probably he used some
> old gcc. Anyway its not excuse for abusing __djgpp_nearptr_enable() that's
> potentially dangerous...

Yikes. Well, it's not THAT surprising. I think we take stability for granted and just assume everything always works (probably a bad idea). :-(

Well, low-level system stuff is very confusing and complicated, even under the best of circumstances. You know, I've even had Linux hang and crash on me (and Android much moreso). Nothing is immune to bugs. Sorry for your pain, though, but what "backup" do you use? I'd just copy it to a bootable USB jump drive, personally.

 

Complete thread:

Back to the forum
Board view  Mix view
15112 Postings in 1359 Threads, 247 registered users, 14 users online (0 registered, 14 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum