Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

WheelK : at last, use that mouse =wheel= in DOS ! (Announce)

posted by Ninho(R) E-mail, 07.08.2016, 00:19

> I tried it but it doesn't work for me (MS intelli mouse exploerer 3.0 via
> PS/2). E.g. in file manager or links wheel does nothing. But in native
> wheel programs like Arachne, MPXplay, Quake2dos wheel works fine.

Please qualify "doesn't work". Does WheelK load itself OK or does its loading fail ? Please report what it prints while trying to load.

Just to be sure, is your CTMouse version current (2.0 or 2.1b4) ? If 2.1, you MUST give it option "/O", with 2.0 it was the opposite (/O meant no wheel !).

Assuming WheelK loads OK after CTMouse, it could be something with your DOS configuration is interfering, or the specific programs you have tried could be incompatible with the BIOS-buffer stuffing method used by WheelK to simulate key presses. I do not have links nor the 'which?) file manager.

Could you try a few more programs so we can narrow the problem ? Programs I am sure "just work" with WheelK for having tried myself : 4DOS (wheel scrolls thru command history), idem DosKey under MSDOS . Buerg's "list". Dos port of Lynx 2.8.5...

Don't hesitate to (re)enable WheelK after running "mouse conscious" programs, for instance, as noted above the wheel works at the 4DOS command line (for me), but if you type F1 to get 4DOS help, that installs its own mouse hook which disables WheelK's - you must reenable WheelK after exiting 4DOS's help. And pretty much so after running any programme which has native mouse processing (wheel or no wheel).

If decidely WheelK won't work for you, we'd have to scan and review possible configuration issues both software and hardware in detail.



Complete thread:

Back to the forum
Board view  Mix view
15317 Postings in 1383 Threads, 254 registered users, 15 users online (0 registered, 15 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum