Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

Debugging HX applications under WD for DOS (Developers)

posted by danielnice(R), 28.08.2017, 21:21

I want to make protected mode DOS programs using HX DOS Extender in assembler.
Before I write anything complicated, I'm trying to get the debugging environment to work (WD.EXE) and I am having problems.

I have set up WATCOM and installed HX DOS Extender per the instructions.

After much experimenting with JWASM, I gave up on it and went with plain WASM.
All of the examples in HX say to use MASM + LINK but I do not have the latest versions of the Microsoft tools.

So, I used WASM and WLINK and this gave me "source level debugging", but no global or local variables populate the expected windows under WD (for DOS).

Can anyone help me get the local and global variables to show up under WD using the below program as an example? Further down I give the exact command-line for WASM and WLINK that I used.

Here is the sample program I want to debug:
======================
Contents of SAMPLE.ASM:
======================
.386
.model flat

.code
str1 db 13,10,"Hello, world!",13,10,"$"

testproc PROC
LOCAL test1:WORD
LOCAL test2:DWORD

Mov test1,1
Mov test2,2

Ret
testproc Endp

main proc c
Call testproc

Mov AH,9
Mov EDX, offset str1
Int 21h
Mov AX,4C00h
Int 21h

Ret
main Endp
End main
======================
======================
Here were my exact options:
======================
WASM -D1 -Fo=sample.obj sample.asm
WLINK @sample.lnk

======================
Contents of SAMPLE.LNK:
======================
FILE 'sample.obj'
NAME 'sample.exe'
SYSTEM HXNT
OPTION STACK=16000
OPTION STUB=loadpe.bin
RUNTIME CONSOLE

Any help is appreciated.
-Daniel Nice

 

Complete thread:

Back to the forum
Board view  Mix view
15108 Postings in 1358 Threads, 245 registered users, 10 users online (0 registered, 10 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum