Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

DR-DOS Enhancement Project (Announce)

posted by lproven(R) Homepage E-mail, Prague, Czechia, 17.11.2017, 00:49

> Maybe the boot loader doesn't like your partition layout/ID?
>
> Try using GRUB4DOS to chainload DR-DOS' DRBIO.SYS.

Good thought -- thanks.

I have managed to trace it tonight.

The last version Udo Kuhnt released was 7.01-08:

https://archiveos.org/drdos/

The Zip contains what appears to be the image of a boot diskette: DISK.IMG

But it isn't.

First, it's the wrong size. VirtualBox can't mount it. VMware can.

I truncated it to exactly 2880 sectors using the advice from ``jleg094'' here:

https://forums.virtualbox.org/viewtopic.php?f=4&t=39141

VBox mounts that. But neither boots -- it just displays 2 dots.

I didn't think to check what was on the image! Foolish of me.

I mounted it on a pre-booted VM and looked, and it's blank! There's nothing in the image at all.

So, I mounted the empty image file as a loop device, copied the boot files in there and then the rest of the files in the distro archive.

And lo! It works! It boots my VM just fine, and it's now running 7.01-08!

All I need to do now is work out how to make the hard disk bootable, and I'm in business.

---
--
Liam Proven Profile: https://about.me/liamproven

 

Complete thread:

Back to the forum
Board view  Mix view
15188 Postings in 1365 Threads, 250 registered users, 16 users online (0 registered, 16 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum