Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

Help need. Some network programs for DOS just lockups. (Miscellaneous)

posted by aleksej(R), 29.09.2018, 13:59
(edited by aleksej on 29.09.2018, 21:19)

For first - sorry for my ugly english.

I have 486-class system (mentioned here if interested) based on some kind of embedded chipset and aimed mainly to various embedded and industrial purposes.

Short tech specs:
Advantech PCA-6740 ISA SBC (single board computer) as motherboard.
STPC Elite 133Mhz (Cyrix Cx486 core based SoC cpu+chipset, 66mhz FSB, 2x multiplier).
32mb SDRAM onboard mem (66 / 100mhz).
SMI LynxEM+ SM712G 4mb PCI bus integrated video.
Raltek RTL8139C onboard LAN.
Award/Phoenix Bios v6.0 bios.

It suits for my hobby tasks quite well - it cold, silent and very reliable. I do not want to change it to something else. It have some quirks with DMA and integrated video but eventually I have got used to them or found ways to workaround some of it.

But not all, unfortunatelly. Main issue is still unsolved.

I will try to formulate it short like this: it lockups with every (which i know and tried) piece of *NIX network software ported to DOS with DJGPP and dated before late 2002. Confused? Mmm, i too.

Now a little longer and informative.

What software i tried:
Links browser.
CURL.
WGET.
BSFLite (AIM/ICQ client).
BinkD (TCP/IP driven FTN mailer).

What do they have in common? All of them is console network utilities and all of them not DOS native software, but ported. And ported from some Unix/BSD environment, if I'm not mistaken. And all of them ported to DOS by DJGPP suite, again, if I'm not mistaken. And all of them use WATTCP/WATT-32 API for network functionality in DOS environment.

Every utility mentioned above lockups on this mobo without any error messages right after run. In various versions of pure DOS (with rtspkt packet driver), in Windows 9X DOS box (with NDIS3PKT driver). Ofcourse i tried many software configurations and clean boot million times and digged all bios setting.

Some thoughts.
WGET v1.82. Oldest ported to DOS version which i found. And it - SURPRISINGLY - works just fine. In pure DOS and Win9X DOS box. It dated by late 2002. Later version which i tried lockups too. Such older ports (dated around 2002) of another mentioned software i just didn't found for further testing.
7zip. Another ported to DOS proggy. And again it DJGPP driven. All tested versions (including most recent) just works. Because... it is not a network software.
Arachne browser. All version include last 1.97GPL (dated 2013) works flawlessy. But it native DOS program, not ported from *NIX.

In what way i should dig now? Find/request sources of that problematic ports from it authors and try to recompile with some obsolete DJGPP versions?

I'm a not programmer. And i didn't write any line of code in my life unfortunatelly. This is pure mystical craft for me.

Nevertheless i guess DJGPP is the main issue in that.

Any thoughts? Really hope for your help, guys.
Thanks.

 

Complete thread:

Back to the forum
Board view  Mix view
15673 Postings in 1427 Threads, 259 registered users, 14 users online (1 registered, 13 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum