Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

MPLAYER poorformance (FloX's issue moved from other forum) (DOSX)

posted by DOS386(R), 13.08.2007, 06:52

FloX wrote:

> juhu! Now it works? but bad things:
> * it is very slow
> * doesn?t support sound blaster live ;-)
> * doesn?t switch back to text mode
> So QV is still first choice?

I wrote:

> > slow
> Known issue :-( A native DOS player would be faster ?
> > doesn?t support sound blaster live
> Maybe with HX 2.20 or 3.0 ;-)
> > doesn?t switch back to text
> Works for me. Bugged VESA ?
> > QV is still first choice
> No OGG Theora :-(

Japheth wrote:

> > doesn?t support sound blaster live
> I also have a SB Live. Since this card is SB16 compatible, it works with mplayer.
> > Known issue :-( A native DOS player would be faster ?
> Yes, may be 1% faster. I doubt this will change the impression from "slow" to
> "wow, super fast". Things which REALLY fasten things: 1. use VESAMTRR, 2. don?t
> load the mouse driver (reading video memory is VERY slow), 3. don?t run
> mplayer fullscreen.

-------------------------------------------------------------

> Since this card is SB16 compatible, it works with mplayer

SB Live (PCI IIRC ? ) compatible (by hardware ? ) with SB16 (ISA ? ) ? I always considered this as a lie coming from "Creative" :no:

> may be 1% faster

Is the "loss" caused by OGL emulation via VESA that negligible ?

> 2. don?t load the mouse driver

Doesn't work ... no effect or up to cca 2% (!!!) speedup at best :no:

> 3. don?t run mplayer fullscreen.

Very big effect ... where (MP or HX ?) and how ( NN / linear / bilinear / Lancosz / ... ) is the scaling done ?

> 1. use VESAMTRR

Almost dummy :no: ... up to 5% speedup ...

From my recent tests MP wastes cca:

- 60% of the time in the scaling of "-fs"
- 30% in the codecs
- 10% by writing into LFB

So, very "easy" solution: don't use "-fs" or speed it up / port the/some codecs to ASM and optimize them "correctly" :lol3:

But there is still some mystery here :confused: ... transcoding to a less CPU hoggy codec does not help much either ... and nor reducing bpp ... maybe an odd timer bug ?

---
This is a LOGITECH mouse driver, but some software expect here
the following string:*** This is Copyright 1983 Microsoft ***

 

Complete thread:

Back to the forum
Board view  Mix view
15113 Postings in 1359 Threads, 249 registered users, 27 users online (0 registered, 27 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum