Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

Some links ... (DOSX)

posted by Japheth(R) Homepage, Germany (South), 22.07.2007, 08:37

> Okay, I will test it some more, but like I said, it doesn't work for me on
> real MS-DOS 6.22 (the "standard" DOS) w/ my Intel 486 Sx/25 8 MB RAM. I
> assume you are using some later version of MS-DOS, 7.10 perhaps, on your
> AMD 486?? How much RAM does it have? FPU? What programs do you run
> successfully with only HimemX loaded? What programs do you think I
> should test / try to run?

It's a 80486 DX2 66 Mhz (with 8 MB RAM + FPU)

> (I can only guess you also want more specific info from me: AUTOEXEC.BAT,
> CONFIG.SYS, MS-DOS timestamps and version, programs timestamps and
> versions, 486 stats, etc.) In testing I used no AUTOEXEC.BAT and the
> CONFIG.SYS only had "DEVICE=C:\TEMP\HIMEMX.EXE" in it.

I don't think this is important. Since you already told us that there are no problems with HimemX + Jemm386, there are only 2 things which might fail: the XMS block move function and the A20 functions (both are handled by Jemm386 once it is loaded).

Since everything apparently works in FreeDOS (and in MS-DOS 7.1, which I used for testing), I'm assuming that the XMS block move works now for 80486 ... and the A20 thing is the one which might cause the troubles on your machine.

What does HimemX tell about the A20 method it uses?

---
MS-DOS forever!

 

Complete thread:

Back to the forum
Board view  Mix view
15112 Postings in 1359 Threads, 249 registered users, 22 users online (0 registered, 22 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum