Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

HXRT regression : paq8o8zw doesn't run anymore (DOSX)

posted by Rugxulo(R) Homepage, Usono, 08.06.2008, 03:22
(edited by Rugxulo on 08.06.2008, 03:47)

Hi Japheth,
I guess you know I've been working on a port of PAQ8o8 to DOS. Well, for various reasons, I ended up also making a Win32 port (much easier due to multi-target ability of OpenWatcom). However, back in January of this year, I successfully ran the Win32 version under HXRT in pure DOS (on my P4). Now, however, I've tried it again, and it no longer works. So, I'm guessing that something broke on your end since then. So, whatever previous version worked, but the latest HXRT.ZIP doesn't. Even without custom DOS stub or UPX or .ASM additions (-dNOASM), it still borks (lots of garbage), just by invoking without arguments! (It works fine in real Windows, FYI.)

Test files are here: (w/ srcs)


Complete thread:

Back to the forum
Board view  Mix view
15317 Postings in 1383 Threads, 254 registered users, 18 users online (0 registered, 18 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum