Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

HXRT regression : paq8o8zw doesn't run anymore (DOSX)

posted by Japheth(R) Homepage, Germany (South), 08.06.2008, 10:59
(edited by Japheth on 08.06.2008, 17:35)

> Hi Japheth,
> I guess you know I've been working on a port of PAQ8o8 to DOS. Well,
> for various reasons, I ended up also making a Win32 port (much easier due
> to multi-target ability of OpenWatcom). However, back in January of this
> year, I successfully ran the Win32 version under HXRT in pure DOS (on my
> P4). Now, however, I've tried it again, and it no longer works. So, I'm
> guessing that something broke on your end since then. So, whatever
> previous version worked, but the latest HXRT.ZIP doesn't. Even without
> custom DOS stub or UPX or .ASM additions (-dNOASM), it still borks (lots
> of garbage), just by invoking without arguments! (It works fine in real
> Windows, FYI.)
>
> Test files are here:
> paq8o8z-jun7.zip
> (w/ srcs)

I can confirm this problem. It's related to SEH, the current thread's EFlags register content is destroyed in the exception handler..

[EDIT]: a HXRTD package has been uploaded where this bug is hopefully fixed:

this one

[/EDIT]

---
MS-DOS forever!

 

Complete thread:

Back to the forum
Board view  Mix view
15110 Postings in 1359 Threads, 247 registered users, 11 users online (0 registered, 11 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum