Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

HX + SDL (Wolf4SDL) (DOSX)

posted by Arjay(R), 13.12.2009, 14:08
(edited by Arjay on 13.12.2009, 15:41)

> I just now tried to use WGET from this P4, and it didn't work. But things
> like that used to work all the time until the "auto-migrated" everything
> from Google Pages to Google Sites (approx. three weeks ago).
> So it's their issue, and something I'm not normally aware of. :-(

Well having quickly looked at this. I can see that Google aren't actively blocking WGET via either Googlesites or Googlepages robots.txt's files. However.... what they have clearly done recently is migrate Google Sites to their new method of content load balancing, which basically involves their custom Linux servers sending browsers lots of HTTP 302's redirects to session based content thus the traditional simple usage of WGET et al can get easily broken for several reasons such as needing to follow the URL's which are unique to that session. With WGET you can see this easily if you remember to use the -v (lowercase v) to ensure you see verbose output.

In addition for added fun, another reason for WGET getting broken is if you are using WGET under a modern Windows box... if you are then be aware of the important nasty watch out with later versions of Windows which is the need to escape certain characters such as & with a ^, e.g. ^& in the command-line instead of just &.

& is a particular pain under modern Windows shells as it is used to separate command-lines, however as you may know already it is also exactly the same character used to separate parameters on web URL's... doh! Thus what this means is if you need to directly feed a URL to a program like WGET containing for example, a & character then the & character (and others) MUST be escaped first otherwise those characters will get interpreted by the Windows shell... in the case of & in particular that gets interpreted as telling Windows (every time it sees it) that you would like to run another totally separate command-line, so not only is it "removed" from the original command-line, but the command-line is truncated at that point before the rest of the command-line text is then interpreted as another command-line until it reaches another & where upon... and so it goes on until you either run out of &'s or text for command-line(s!)... and guess what? Google's use a lot of &'s for URL parameters in their newer URL's.... enjoy! ;-)

> The other day (for fun) I halfway tried to see how hard it would be to
> build with Turbo C++ 1.01 and ArrowASM 2.00d, but I got somewhat
> frustrated and gave up. Ideally, it would compile with TC++ (closed source
> but 8086 friendly) or OpenWatcom 16-bit (386 host only but open source)
> too, but neither's possible just yet.
Perhaps Fabrice Bellard's TCC?

> Mike did all the work, I'm just collecting it and posting it publicly
Yeah I realize but that in itself is a lot of work. More than most realize.

> (among other notes and random stuff) since I like the game (and Doom,
> Quake, etc).
Likewise. I still like Wolf though as it was there first ;)

 

Complete thread:

Back to the forum
Board view  Mix view
15194 Postings in 1365 Threads, 250 registered users, 18 users online (1 registered, 17 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum