Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

Quick question about hxdos (DOSX)

posted by Rugxulo(R) Homepage, Usono, 05.07.2010, 16:22

> Just been using hxdos ( ) in freedos along
> with the windows version of qemu (version 0.9.0). I've managed to run
> an old copy of win95 successfully (though I no longer use windows)
> and basiclinux, both seem to be a bit slow but usable.

BasicLinux supports UMSDOS, so it should run native speed atop FreeDOS. ;-)
Win95 probably can also run (via image file) with GRUB4DOS, but I've never tried. (QEMU is not known for blazing speed, or at least not when I tried it.)

> The first problem which seems to affect all machines is the mouse
> seems to be very stuttery or jerky. Is there any way I can make
> the mouse pointer move more smoothly?

What mouse driver are you using? Cutemouse 2.1b4 is the latest, IIRC, so try that (and/or 2.0 and 1.9). However, it could be a BIOS bug. At least my laptop doesn't work with Cutemouse due to that. But I remember DOS386 and Japheth always complaining about various bugs in keyboard handling and mouse support. (Or maybe I'm thinking of BOCHS, I forget.) So it might just be a "bug" in QEMU itself!

> The second problem is more serious though. The 3 machines I'm using are a
> AMD Phenom II quad core (4GB Ram, desktop),

Yes, let those other three cores sleep, they deserve a break. :rotfl:

> a Pentium 4 machine (1GB Ram,

whhhhiiiirrrrrrrr *fan*

> desktop) and an EEEPC (1GB Ram).

Heh, I could never help but laugh at that name, esp. with all the anti-MS sentiment in the Linux community.

> The problem concerns hxdos and the "-full-screen" option. I can get qemu to
> run, but if I try to use the "-full-screen" option on either of the desktop
> PCs (the EEE PC works fine) I get this error message;
> dkrnl32: exception
> dkrnl32: fatal exit!

Could be a bug in HXGUI, but ...

> Both desktop PCs give this error if I do something like this;
> dpmild32 -g qemu.exe -L . -m 32 -hda hdd -boot c -full-screen
> but the EEE PC gives no error at all!


> Does anyone know why full screen wouldn't work (and how to make the mouse
> smoother?)

Might be a VESA BIOS bug as they all have subtle quirks. You could try UNIVBE and see if that helps, but don't get your hopes up.

Know your limits.h


Complete thread:

Back to the forum
Board view  Mix view
15296 Postings in 1378 Threads, 254 registered users, 12 users online (0 registered, 12 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum