Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to index page
Thread view  Board view
Ninho(R)

E-mail

03.07.2011, 23:17
 

Nasty bug in FDEBUG 1.23 (assembler) (Miscellaneous)

The assembler is confused and assembles erroneously without warning instructions using "SIB" such as :

mov eax,[esp]
mov [esp],eax
mov eax,[esp+02] ...

probably a lot of others :-(

FDebug 1.21 did NOT have this bug (I passed over 1.22)

---
Ninho

Japheth(R)

Homepage

Germany (South),
04.07.2011, 09:48

@ Ninho
 

Nasty bug in FDEBUG 1.23 (assembler)

> The assembler is confused and assembles erroneously without warning
> instructions using "SIB" such as :
>
> mov eax,[esp]
> mov [esp],eax
> mov eax,[esp+02] ...
>
> probably a lot of others :-(

Ok, thanks!

However, what makes you decide that there are "probably a lot of others"?

Also, it's not a nasty bug, it's virtually the opposite: an interesting, nice little regression in v1.23.

And finally: It's fixed in scheduled v1.24 ... you may download the fixed version from my site.

---
MS-DOS forever!

Ninho(R)

E-mail

04.07.2011, 11:23

@ Japheth
 

Nasty bug in FDEBUG 1.23 (assembler)

> Ok, thanks!
>
> However, what makes you decide that there are "probably a lot of
> others"?

Ne'er mind, by that phrase I simply meant I didn't attempt any exhaustive checking -
nor looked at the source.

> Also, it's not a nasty bug, it's virtually the opposite: an
> interesting, nice little regression in v1.23.

'Interesting'... is an understatement. I find it nasty indeed, as it strikes
the unsuspecting innoncent. Insidious if you prefer :=)


> And finally: It's fixed in scheduled v1.24 ... you may download the fixed
> version from my site.

Superb, thanks!

---
Ninho

Back to index page
Thread view  Board view
15108 Postings in 1358 Threads, 245 registered users, 11 users online (0 registered, 11 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum