Back to home page

DOS ain't dead

Forum index page

Log in | Register

Back to index page
Thread view  Board view
ljones(R)

05.07.2010, 00:13
 

Quick question about hxdos (DOSX)

hello all :)

Just been using hxdos ( http://www.japheth.de/HX.html ) in freedos along with the windows version of qemu (version 0.9.0) . Most things seem to be working well, less a couple of things. I've managed to run an old copy of win95 successfully (though I no longer use windows) and basiclinux, both seem to be a bit slow but usable.

Unfortunatly I'm experiencing a couple of problems however. I've tried my current setup (freedos and hxdos) on 3 systems now. The first problem which seems to affect all machines is the mouse seems to be very stuttery or jerky. Is there any way I can make the mouse pointer move more smoothly?

The second problem is more serious though. The 3 machines I'm using are a AMD Phenom II quad core (4GB Ram, desktop), a Pentium 4 machine (1GB Ram, desktop) and an EEEPC (1GB Ram).

The problem concerns hxdos and the "-full-screen" option. I can get qemu to run, but if I try to use the "-full-screen" option on either of the desktop PCs (the EEE PC works fine) I get this error message;

wsock32: no packet driver found.

dkrnl32: exception C0000005, flags=0 occured at BF:32E901
ax=ADD8ADD8 bx=61D0000 cx=ADD8ADD8 dx=620EC34
si=50D00000 di=2244FB0 bp=322B38 sp=322B24
exception caused by access to memory address ADD8ADDC
ip=Module 'kernel32.dll'+2901
[eip]=8b 40 04 23 c0 75 f1 23 c0 74 21 8b
[esp]=00330a27 00000bf 00003246 00000005 00322928 0032f69e
dkrnl32: fatal exit!
WSAStartup: 0
Could not open 'kqemu' - QEMU acceleration layer not activated: No error

C:HX>_

Both desktop PCs give this error if I do something like this;

dpmild32 -g qemu.exe -L . -m 32 -hda hdd -boot c -full-screen

but the EEE PC gives no error at all! Qemu runs ok if I leave off the "-full-screen" option and use the keyboard hotkey to switch to full screen mode after everything has loaded.

I'm using the exact same versions of qemu, hxdos and freedos on all 3 machines.

Does anyone know why full screen wouldn't work (and how to make the mouse smoother?)

thanks

ljones

rr(R)

Homepage E-mail

Berlin, Germany,
05.07.2010, 10:12

@ ljones
 

Quick question about hxdos

> Could not open 'kqemu' - QEMU acceleration layer not activated: No error

It's probably not related, but AFAIK QEMU with kqemu is not supported on HX/DOS. Please try the "-no-kqemu" option.

Rugxulo(R)

Homepage

Usono,
05.07.2010, 16:22

@ ljones
 

Quick question about hxdos

> Just been using hxdos ( http://www.japheth.de/HX.html ) in freedos along
> with the windows version of qemu (version 0.9.0). I've managed to run
> an old copy of win95 successfully (though I no longer use windows)
> and basiclinux, both seem to be a bit slow but usable.

BasicLinux supports UMSDOS, so it should run native speed atop FreeDOS. ;-)
Win95 probably can also run (via image file) with GRUB4DOS, but I've never tried. (QEMU is not known for blazing speed, or at least not when I tried it.)

> The first problem which seems to affect all machines is the mouse
> seems to be very stuttery or jerky. Is there any way I can make
> the mouse pointer move more smoothly?

What mouse driver are you using? Cutemouse 2.1b4 is the latest, IIRC, so try that (and/or 2.0 and 1.9). However, it could be a BIOS bug. At least my laptop doesn't work with Cutemouse due to that. But I remember DOS386 and Japheth always complaining about various bugs in keyboard handling and mouse support. (Or maybe I'm thinking of BOCHS, I forget.) So it might just be a "bug" in QEMU itself!

> The second problem is more serious though. The 3 machines I'm using are a
> AMD Phenom II quad core (4GB Ram, desktop),

Yes, let those other three cores sleep, they deserve a break. :rotfl:

> a Pentium 4 machine (1GB Ram,

whhhhiiiirrrrrrrr *fan*

> desktop) and an EEEPC (1GB Ram).

Heh, I could never help but laugh at that name, esp. with all the anti-MS sentiment in the Linux community.

> The problem concerns hxdos and the "-full-screen" option. I can get qemu to
> run, but if I try to use the "-full-screen" option on either of the desktop
> PCs (the EEE PC works fine) I get this error message;
>
> dkrnl32: exception
> dkrnl32: fatal exit!

Could be a bug in HXGUI, but ...

> Both desktop PCs give this error if I do something like this;
>
> dpmild32 -g qemu.exe -L . -m 32 -hda hdd -boot c -full-screen
>
> but the EEE PC gives no error at all!

Hmmmm....

> Does anyone know why full screen wouldn't work (and how to make the mouse
> smoother?)

Might be a VESA BIOS bug as they all have subtle quirks. You could try UNIVBE and see if that helps, but don't get your hopes up.

---
Know your limits.h

Arjay(R)

05.07.2010, 22:14
(edited by Arjay, 06.07.2010, 16:43)

@ Rugxulo
 

Quick question about hxdos

>> The first problem which seems to affect all machines is the mouse
>> seems to be very stuttery or jerky.
> However, it could be a BIOS bug.
I doubt it is a BIOS bug if it is affecting 3 separate non-identical machines.

> At least my laptop doesn't work with Cutemouse due to that.
I do remember seeing something similar myself with Cutemouse some time ago which I worked around. I think it may have used Cutemouse's /P option to force PS2 mode or /Y or /S - I would give them a try.

> Yes, let those other three cores sleep, they deserve a break. :rotfl:
Lol

> > but the EEE PC gives no error at all!
> Hmmmm....
Interesting. From some past low level testing with a borrowed EEE PC I do know that they are fairly strict in some ways, e.g. if you use a bootable disk which is missing the 55AAh signature it is very unlikely to boot on an EEE PC. This is "correct" by the book but also means there are things that EEE PC's won't boot (e.g. some Linux stuff, Flopper's install disk) which will boot fine on other IBM PC clones which don't observe that rule properly. In this instance the EEE PC is "correct" it is just that not everyone else is following observing the same rule.

ljones(R)

05.07.2010, 21:29

@ ljones
 

Quick question about hxdos

Well, I have an answer or rather a workaround to this. Sort of - !

Unfortunatly the -no-kqemu option didn't seem to have any effect, and univbe (the last version, 6.7) didn't work either - my graphics card is just too new for univbe.

So I decided to give basiclinux a try which worked even with the "-full-screen" option. Intrestingly it worked without giving me any errors which was intresting. I also noted it starts up in text mode.

After a bit of reading I decided to retry that old win95 install/image I tried and which gave the problems. But I had an idea -- I edited msdos.sys (attrib -r -h -s msdos.sys) so that the options section says:

[options]
Logo=0
BootMulti=0
BootGUI=1
Network=1

This disables the startup screen and intrestingly it works! It appears then that there's something between hx, qemu and win95 which some part of it somewhere dosen't like!

ljones

Arjay(R)

05.07.2010, 21:59

@ ljones
 

Quick question about hxdos

> [options]
> Logo=0
[snip]

> This disables the startup screen and intrestingly it works!
The 9x startup screen uses Mode X (320x240) with a partial palette rotate.

Japheth(R)

Homepage

Germany (South),
06.07.2010, 15:53

@ ljones
 

Quick question about hxdos

> Unfortunatly I'm experiencing a couple of problems however. I've tried my
> current setup (freedos and hxdos) on 3 systems now. The first problem which
> seems to affect all machines is the mouse seems to be very stuttery or
> jerky. Is there any way I can make the mouse pointer move more smoothly?

I don't know. Qemu has some problems with correct emulation of legacy devices - emulation of enhanced keys on the keyboard is one the most annoying issues. However, it may also be a problem with HX's Win32 timer emulation.

> The problem concerns hxdos and the "-full-screen" option. I can get qemu to
> run, but if I try to use the "-full-screen" option on either of the desktop
> PCs (the EEE PC works fine) I get this error message;
>
> wsock32: no packet driver found.
>
> dkrnl32: exception C0000005, flags=0 occured at BF:32E901
> ax=ADD8ADD8 bx=61D0000 cx=ADD8ADD8 dx=620EC34
> si=50D00000 di=2244FB0 bp=322B38 sp=322B24
> exception caused by access to memory address ADD8ADDC
> ip=Module 'kernel32.dll'+2901
> [eip]=8b 40 04 23 c0 75 f1 23 c0 74 21 8b
> [esp]=00330a27 00000bf 00003246 00000005 00322928 0032f69e
> dkrnl32: fatal exit!

I'll try to reproduce that.

---
MS-DOS forever!

Back to index page
Thread view  Board view
15186 Postings in 1365 Threads, 250 registered users, 16 users online (0 registered, 16 guests)
DOS ain't dead | Admin contact
RSS Feed
powered by my little forum